Skip to content

← Public intelligence

RubyGems package

rest-client

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    rest-client Gem Vulnerable to Session Fixation

    CVE-2015-1820 · GHSA-3fhf-6939-qg8p

    Affected
    • RubyGems rest-client >= 1.6.1.a, < 1.8.0
    Fixed in
    1.8.0· Vendor fix available
    Issue
    REST client for Ruby (aka rest-client) versions 1.6.1.a until 1.8.0 allow remote attackers to conduct session fixation attacks or obtain sensitive cookie information by leveraging passage of cookies set in a response to a redirect.

    Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    rest-client allows local users to obtain sensitive information by reading the log

    CVE-2015-3448 · GHSA-mx9f-w8qq-q5jf

    Affected
    • RubyGems rest-client < 1.7.3
    Fixed in
    1.7.3· Vendor fix available
    Issue
    REST client for Ruby (aka rest-client) before 1.7.3 logs usernames and passwords, which allows local users to obtain sensitive information by reading the log.

    Recommended action: Upgrade to 1.7.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →