Skip to content

← Public intelligence

RubyGems package

request_store

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9RubyGemsPublished

    request_store has Incorrect Default Permissions

    CVE-2024-43791 · GHSA-frp2-5qfc-7r8m

    Affected
    • RubyGems request_store >= 1.3.2, <= 1.3.2
    Fixed in
    1.4.0· Vendor fix available
    Issue
    Impact The files published as part of requeststore 1.3.2 have 0666 permissions, meaning that they are world-writable, which allows local users to execute arbitrary code. This version was published in 2017, and most production environments do not allow access for local users, so the chances of this being exploited are very low, given that the vast majority of users will have upgraded, and those that have not, if any, are not likely to be exposed. Patches I am not aware of any other version of the gem with incorrect permissions, so simply upgrading should fix the issue. Workarounds You could chmod the files yourself, I guess. References https://cwe.mitre.org/data/definitions/276.html

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →