Critical, CVSS 9.8RubyGemsPublished
Recurly gem Server-Side Request Forgery in Resource#find method
CVE-2017-0905 · GHSA-x27v-x225-gq8g
- Affected
- RubyGems recurly >= 2.11.0, < 2.11.3; >= 2.10.0, < 2.10.4; >= 2.9.0, < 2.9.2; >= 2.8.0, < 2.8.2; >= 2.7.0, < 2.7.8; >= 2.6.0, < 2.6.3; >= 2.5.0, < 2.5.4; >= 2.4.0, < 2.4.11; >= 2.3.0, < 2.3.10; >= 2.2.0, < 2.2.5; >= 2.1.0, < 2.1.11; >= 2.0.0, < 2.0.13
- Fixed in
- 2.5.42.3.102.0.132.10.42.9.22.4.112.1.112.11.32.7.82.8.22.6.32.2.5· Vendor fix available
- Issue
- The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource#find method that could result in compromise of API keys or other critical resources.
Recommended action: Upgrade to 2.11.3, 2.10.4, 2.9.2 or 9 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.