Skip to content

← Public intelligence

RubyGems package

pdfkit

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    PDFKit vulnerable to Command Injection

    CVE-2022-25765 · GHSA-rhwx-hjx2-x4qr

    Affected
    • RubyGems pdfkit < 0.8.7.2
    Fixed in
    0.8.7.2· Vendor fix available
    Issue
    The package pdfkit is vulnerable to Command Injection where the URL is not properly sanitized. Note: This issue was patched in 0.8.7.2, but the patch was discovered to be ineffective. The updated patch version is 0.8.7.2.

    Recommended action: Upgrade to 0.8.7.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    PDFKit Improper Input Validation vulnerability

    CVE-2013-1607 · GHSA-39v7-xpq4-8884

    Affected
    • RubyGems pdfkit < 0.5.3
    Fixed in
    0.5.3· Vendor fix available
    Issue
    Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

    Recommended action: Upgrade to 0.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →