Skip to content

← Public intelligence

RubyGems package

paperclip

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8RubyGemsPublished

    paperclip Server-Side Request Forgery vulnerability

    CVE-2017-0889 · GHSA-5jcf-c5rg-rmm8

    Affected
    • RubyGems paperclip >= 3.1.4, < 5.2.0
    Fixed in
    5.2.0· Vendor fix available
    Issue
    Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

    Recommended action: Upgrade to 5.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    paperclip Cross-site Scripting vulnerability

    CVE-2015-2963 · GHSA-6jvm-3j5h-79f6

    Affected
    • RubyGems paperclip < 4.2.2
    Fixed in
    4.2.2· Vendor fix available
    Issue
    The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.

    Recommended action: Upgrade to 4.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →