Skip to content

← Public intelligence

RubyGems package

openssl

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    Ruby OpenSSL DoS Vulnerability

    CVE-2017-14033 · GHSA-v6rp-3r3v-hf4p

    Affected
    • RubyGems openssl < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string. The openssl gem that contains this module is patched in version 2.0.0.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    Ruby Openssl Allows Incorrect Value Comparison

    CVE-2018-16395 · GHSA-mmrq-6999-72v8

    Affected
    • RubyGems openssl < 2.0.9; >= 2.1.0, < 2.1.2
    Fixed in
    2.0.92.1.2· Vendor fix available
    Issue
    An issue was discovered in the OpenSSL library in Ruby when two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    Recommended action: Upgrade to 2.1.2 or 2.0.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5RubyGemsPublished

    OpenSSL gem for Ruby using inadequate encryption strength

    CVE-2016-7798 · GHSA-6h88-qjpv-p32m

    Affected
    • RubyGems openssl < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    The OpenSSL gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes--gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →