Critical, CVSS 9.8RubyGemsPublished
omniauth-weibo-oauth2 included a code-execution backdoor inserted by a third party
CVE-2019-17268 · GHSA-vr22-43gj-rx3f
- Affected
- RubyGems omniauth-weibo-oauth2 >= 0.4.6, < 0.5.1
- Fixed in
- 0.5.1· Vendor fix available
- Issue
- The omniauth-weibo-oauth2 gem 0.4.6 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Versions through 0.4.5, and 0.5.1 and later, are unaffected.
Recommended action: Upgrade to 0.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.