Skip to content

← Public intelligence

RubyGems package

omniauth-facebook

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    omniauth-facebook Improper Authentication vulnerability

    CVE-2013-4593 · GHSA-33vg-hpx5-pfxg

    Affected
    • RubyGems omniauth-facebook < 1.5.1
    Fixed in
    1.5.1· Vendor fix available
    Issue
    RubyGem omniauth-facebook has an access token security vulnerability.

    Recommended action: Upgrade to 1.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    omniauth-facebook Cross-Site Request Forgery vulnerability

    CVE-2013-4562 · GHSA-cf36-985g-v73c

    Affected
    • RubyGems omniauth-facebook >= 1.4.1, < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    The omniauth-facebook gem 1.4.1 before 1.5.0 does not properly store the session parameter, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via the state parameter.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →