Skip to content

← Public intelligence

RubyGems package

omniauth-auth0

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.4RubyGemsPublished

    Regression in JWT Signature Validation

    CVE-2020-15240 · GHSA-58r4-h6v8-jcvm

    Affected
    • RubyGems omniauth-auth0 >= 2.3.0, < 2.4.1
    Fixed in
    2.4.1· Vendor fix available
    Issue
    Versions after and including 2.3.0 are improperly validating the JWT token signature when using the JWTValidator.verify method. Improper validation of the JWT token signature when not using the default Authorization Code Flow can allow an attacker to bypass authentication and authorization. Am I affected? You are affected by this vulnerability if all of the following conditions apply: - You are using omniauth-auth0. - You are using JWTValidator.verify method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. How to fix that? Upgrade to version 2.4.1. Will this update impact my users? The fix provided in this version will not affect your users.

    Recommended action: Upgrade to 2.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →