UnratedRubyGemsPublished
nori contains Improper Input Validation
CVE-2013-0285 · GHSA-4936-rj25-6wm6
- Affected
- RubyGems nori >= 2.0.0, < 2.0.2; >= 1.1.0, < 1.1.4; >= 1.0.0, < 1.0.3
- Fixed in
- 1.1.42.0.21.0.3· Vendor fix available
- Issue
- The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.
Recommended action: Upgrade to 2.0.2, 1.1.4 or 1.0.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.