UnratedRubyGemsPublished
newrelic_rpm Gem Discloses Sensitive Information
CVE-2013-0284 · GHSA-q6cw-2553-7837
- Affected
- RubyGems newrelic_rpm >= 3.2.0, <= 3.5.3.23
- Fixed in
- 3.5.3.24· Vendor fix available
- Issue
- Ruby agent 3.2.0 through 3.5.3.23 serializes sensitive data when communicating with servers operated by New Relic, which allows remote attackers to obtain sensitive information (database credentials and SQL statements) by sniffing the network and deserializing the data.
Recommended action: Upgrade to 3.5.3.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.