Critical, CVSS 9.8RubyGemsPublished
netaddr before 1.5.3 and 2.0.4 has Incorrect Default Permissions
CVE-2019-17383 · GHSA-49pj-69vf-c689
- Affected
- RubyGems netaddr >= 2.0.0, < 2.0.4; < 1.5.3
- Fixed in
- 2.0.41.5.3· Vendor fix available
- Issue
- The netaddr gem before 1.5.3 and 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.
Recommended action: Upgrade to 2.0.4 or 1.5.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.