High, CVSS 7.5RubyGemsPublished
Moped Rubygem Data Injection Vulnerability
CVE-2015-4410 · GHSA-f93j-hmcr-jcwh
- Affected
- RubyGems moped < 1.5.3; >= 2.0.0, < 2.0.5
- Fixed in
- 1.5.32.0.5· Vendor fix available
- Issue
- The Moped::BSON::ObjecId.legal? method in rubygem-moped before commit dd5a7c14b5d2e466f7875d079af71ad19774609b allows remote attackers to cause a denial of service (worker resource consumption) or perform a cross-site scripting (XSS) attack via a crafted string.
Recommended action: Upgrade to 2.0.5 or 1.5.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.