Skip to content

← Public intelligence

RubyGems package

mongrel

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedRubyGemsPublished

    Mongrel vulnerable to directory traversal via double-encoded sequences

    CVE-2007-6612 · GHSA-m7r6-43v2-49vf

    Affected
    • RubyGems mongrel >= 1.0.4, <= 1.0.4; >= 1.1.0, < 1.1.3
    Fixed in
    1.1.31.0.5· Vendor fix available
    Issue
    Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 (1.0.3 and prior are not affected) and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (.%252e).

    Recommended action: Upgrade to 1.1.3 or 1.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →