High, CVSS 7.5RubyGemsPublished
archive-tar-minitar and minitar vulnerable to Path Traversal
CVE-2016-10173 · GHSA-h5g2-38x9-4gv3
- Affected
- RubyGems minitar < 0.6
- Fixed in
- 0.6· Vendor fix available
- Issue
- Directory traversal vulnerability in the minitar before 0.6 and archive-tar-minitar 0.5.2 gems for Ruby allows remote attackers to write to arbitrary files via a .. (dot dot) in a TAR archive entry.
Recommended action: Upgrade to 0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.