Skip to content

← Public intelligence

RubyGems package

mail

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3RubyGemsAmendedPublished

    Mail: Email address spoofing via malformed RFC 2047 encoded-words

    CVE-2026-63435 · GHSA-mvxr-6m87-mv2q

    Affected
    • RubyGems mail < 2.9.1
    Fixed in
    2.9.1· Vendor fix available
    Issue
    Mail::Utilities.qvaluedecode and Mail::Utilities.bvaluedecode decoded only the first RFC 2047 encoded-word in a string and used an overly greedy pattern to match the charset token. A crafted, malformed encoded-word embedded in an address display name or local part could cause the decoded output to differ from what a human reviewer or downstream parser would expect, allowing an attacker to spoof the apparent sender/recipient address. Details Both decoders used a single String#match against a pattern such as /\=\?(.+)?\?[Qq]\?(.)\?\=/m. Two problems: 1. Single match, dropped remainder. Only the first =?charset?Q?...?= (or ?B?) word was decoded. Any additional encoded-words or surrounding text were not handled consistently, so the decoded result could silently omit or alter parts of the input. 2. Greedy charset capture. (.+)? is greedy and matches across ? delimiters, so a malformed word could span more of the string than a strict RFC 2047 parse would, changing the boundary…

    Recommended action: Upgrade to 2.9.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratedRubyGemsPublished

    Mail Improper Input Validation vulnerability

    CVE-2011-0739 · GHSA-cpjc-p7fc-j9xh

    Affected
    • RubyGems mail < 2.2.15
    Fixed in
    2.2.15· Vendor fix available
    Issue
    The deliver function in the sendmail delivery agent (lib/mail/network/deliverymethods/sendmail.rb) in Ruby Mail gem 2.2.14 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in an e-mail address.

    Recommended action: Upgrade to 2.2.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedRubyGemsPublished

    Mail Gem Path Traversal vulnerability

    CVE-2012-2139 · GHSA-cj92-c4fj-w9c5

    Affected
    • RubyGems mail < 2.4.4
    Fixed in
    2.4.4· Vendor fix available
    Issue
    Directory traversal vulnerability in lib/mail/network/deliverymethods/filedelivery.rb in the Mail gem before 2.4.4 for Ruby allows remote attackers to read arbitrary files via a .. (dot dot) in the to parameter.

    Recommended action: Upgrade to 2.4.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. UnratedRubyGemsPublished

    Mail Gem Improper Input Validation vulnerability

    CVE-2012-2140 · GHSA-rp63-jfmw-532w

    Affected
    • RubyGems mail < 2.4.3
    Fixed in
    2.4.3· Vendor fix available
    Issue
    The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery.

    Recommended action: Upgrade to 2.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1RubyGemsPublished

    Mail Gem CRLF Injection vulnerability

    CVE-2015-9097 · GHSA-q86f-fmqf-qrf6

    Affected
    • RubyGems mail < 2.5.5
    Fixed in
    2.5.5· Vendor fix available
    Issue
    The mail gem before 2.5.5 for Ruby (aka A Really Ruby Mail Library) is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.

    Recommended action: Upgrade to 2.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →