Skip to content

← Public intelligence

RubyGems package

lynx

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8RubyGemsPublished

    lynx doesn't properly sanitize user input and exposes database password to unauthorized users

    CVE-2014-5002 · GHSA-94cq-7ccq-cmcm

    Affected
    • RubyGems lynx <= 0.4.0
    Fixed in
    1.0.0· Vendor fix available
    Issue
    The lynx gem prior to 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes. As of version 1.0.0, lynx no longer supports a --password option. Passwords are only configured in a configuration file, so it's no longer possible to expose passwords on the command line.

    Recommended action: Upgrade to 1.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →