Skip to content

← Public intelligence

RubyGems package

logstash-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    Logstash Logs Sensitive Information

    CVE-2016-1000221 · GHSA-vcmm-ppqx-95ch

    Affected
    • RubyGems logstash-core < 2.3.4
    Fixed in
    2.3.4· Vendor fix available
    Issue
    Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

    Recommended action: Upgrade to 2.3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5RubyGemsPublished

    Logstash Logs Sensitive Information

    CVE-2016-10362 · GHSA-3gg4-6hqg-2vjx

    Affected
    • RubyGems logstash-core < 5.0.1
    Fixed in
    5.0.1· Vendor fix available
    Issue
    Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.

    Recommended action: Upgrade to 5.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →