Skip to content

← Public intelligence

RubyGems package

logstash

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1RubyGemsPublished

    Elasticsearch Logstash allows remote attackers to execute arbitrary commands

    CVE-2014-4326 · GHSA-8qhq-rq4j-8prj

    Affected
    • RubyGems logstash >= 1.0.14, < 1.4.2
    Fixed in
    1.4.2· Vendor fix available
    Issue
    Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagiosnsca.rb in outputs/.

    Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →