Skip to content

← Public intelligence

RubyGems package

kafo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedRubyGemsPublished

    Kafo allows local users to obtain passwords and other sensitive information by reading default_values.yaml

    CVE-2014-0135 · GHSA-hxvp-655x-xxqv

    Affected
    • RubyGems kafo < 0.3.17; >= 0.4.0, < 0.5.2
    Fixed in
    0.5.20.3.17· Vendor fix available
    Issue
    Kafo before 0.3.17 and 0.4.x before 0.5.2, as used by Foreman, uses world-readable permissions for defaultvalues.yaml, which allows local users to obtain passwords and other sensitive information by reading the file.

    Recommended action: Upgrade to 0.5.2 or 0.3.17 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →