Skip to content

← Public intelligence

RubyGems package

jekyll

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    Jekyll allows attackers to access arbitrary files by specifying a symlink

    CVE-2018-17567 · GHSA-4xjh-m3qx-49wc

    Affected
    • RubyGems jekyll < 3.6.3; >= 3.7.0, < 3.7.4; >= 3.8.0, < 3.8.4
    Fixed in
    3.6.33.8.43.7.4· Vendor fix available
    Issue
    Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the include key in the config.yml file.

    Recommended action: Upgrade to 3.8.4, 3.7.4 or 3.6.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →