Medium, CVSS 6.1RubyGemsPublished
Inline SVG vulnerable to Cross-site Scripting
CVE-2020-36644 · GHSA-p33q-4h4m-j994
- Affected
- RubyGems inline_svg < 1.7.2
- Fixed in
- 1.7.2· Vendor fix available
- Issue
- A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file lib/inlinesvg/actionview/helpers.rb of the component URL Parameter Handler. The manipulation of the argument filename leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.7.2 is able to address this issue. The name of the patch is f5363b351508486021f99e083c92068cf2943621. It is recommended to upgrade the affected component. The identifier VDB-217597 was assigned to this vulnerability.
Recommended action: Upgrade to 1.7.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.