Medium, CVSS 5.9RubyGemsPublished
http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor
CVE-2015-1828 · GHSA-6wpv-cj6x-v3jw
- Affected
- RubyGems http >= 0.7.0, < 0.7.3; < 0.6.4
- Fixed in
- 0.7.30.6.4· Vendor fix available
- Issue
- The Ruby http gem before 0.6.4 and 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.
Recommended action: Upgrade to 0.7.3 or 0.6.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.