Skip to content

← Public intelligence

RubyGems package

graphql

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3RubyGemsPublished

    GraphQL-Ruby's Ruby lexer does not count comment tokens for the purposes of max_query_string_tokens

    GHSA-3h96-34p3-xm76

    Affected
    • RubyGems graphql >= 2.6.0, <= 2.6.0; >= 2.5.0, < 2.5.26; >= 2.4.0, < 2.4.18; >= 2.3.1, < 2.3.23
    Fixed in
    2.3.232.5.262.4.182.6.1· Vendor fix available
    Issue
    GraphQL-Ruby's maxquerystringtokens configuration didn't count comment tokens against the limit, allowing strings to be processed even after the configured maximum had actually been reached. In patched versions, the Ruby lexer does count these tokens. GraphQL-CParser is not affected by this problem. maxquerystringtokens was introduced in v2.3.1. Each 2.x version has received a new patch release for including a fix.

    Recommended action: Upgrade to 2.6.1, 2.5.26, 2.4.18 or 2.3.23 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.0RubyGemsPublished

    graphql allows remote code execution when loading a crafted GraphQL schema

    CVE-2025-27407 · GHSA-q92j-grw3-h492

    Affected
    • RubyGems graphql >= 2.4.0, < 2.4.13; >= 2.3.0, < 2.3.21; >= 2.0.0, < 2.0.32; >= 1.13.0, < 1.13.24; >= 1.12.0, < 1.12.25; >= 2.1.0, < 2.1.15; >= 1.11.5, < 1.11.11; >= 2.2.0, < 2.2.17
    Fixed in
    2.2.172.3.211.11.112.4.131.13.242.1.151.12.252.0.32· Vendor fix available
    Issue
    Loading a malicious schema definition in GraphQL::Schema.fromintrospection (or GraphQL::Schema::Loader.load) can result in remote code execution. Any system which loads a schema by JSON from an untrusted source is vulnerable, including those that use GraphQL::Client to load external schemas via GraphQL introspection.

    Recommended action: Upgrade to 2.4.13, 2.3.21, 2.2.17 or 5 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →