Low, CVSS 3.2RubyGemsPublished
Gitaly Insufficient Session Expiration vulnerability
CVE-2020-13353 · GHSA-mmmm-chjf-jmvw
- Affected
- RubyGems gitaly >= 1.79.0, < 13.3.9; >= 13.4, < 13.4.5; >= 13.5, < 13.5.2
- Fixed in
- 13.5.213.3.913.4.5· Vendor fix available
- Issue
- When importing repos via URL, one time use git credentials were persisted beyond the expected time window in Gitaly 1.79.0 or above. Affected versions are: =1.79.0, <13.3.9,=13.4, <13.4.5,=13.5, <13.5.2.
Recommended action: Upgrade to 13.5.2, 13.4.5 or 13.3.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.