Critical, CVSS 9.8RubyGemsPublished
OS Command Injection in ftpd
CVE-2013-2512 · GHSA-7vxr-6cxg-j3x8
- Affected
- RubyGems ftpd < 0.2.2
- Fixed in
- 0.2.2· Vendor fix available
- Issue
- The ftpd gem 0.2.1 for Ruby allows remote attackers to execute arbitrary OS commands via shell metacharacters in a LIST or NLST command argument within FTP protocol traffic.
Recommended action: Upgrade to 0.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.