High, CVSS 7.8RubyGemsPublished
Ruby-ffi has a DLL loading issue
CVE-2018-1000201 · GHSA-2gw2-8q9w-cw8p
- Affected
- RubyGems ffi < 1.9.24
- Fixed in
- 1.9.24· Vendor fix available
- Issue
- ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be hijacked on Windows OS, when a Symbol is used as DLL name instead of a String This vulnerability appears to have been fixed in v1.9.24 and later.
Recommended action: Upgrade to 1.9.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.