Skip to content

← Public intelligence

RubyGems package

em-http-request

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.4RubyGemsPublished

    Improper Certificate Validation in EM-HTTP-Request

    CVE-2020-13482 · GHSA-q27f-v3r6-9v77

    Affected
    • RubyGems em-http-request <= 1.1.5
    Fixed in
    1.1.6· Vendor fix available
    Issue
    EM-HTTP-Request 1.1.5 uses the library eventmachine in an insecure way that allows an attacker to perform a man-in-the-middle attack against users of the library. The hostname in a TLS server certificate is not verified.

    Recommended action: Upgrade to 1.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →