Skip to content

← Public intelligence

RubyGems package

dragonfly

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1RubyGemsPublished

    Arbitrary file write in dragonfly

    CVE-2021-33473 · GHSA-fj34-jhjx-xmvv

    Affected
    • RubyGems dragonfly < 1.4.0
    Fixed in
    1.4.0· Vendor fix available
    Issue
    An argument injection vulnerability in Dragonfly Ruby Gem v1.3.0 allows attackers to read and write arbitrary files when the verifyurl option is disabled. This vulnerability is exploited via a crafted URL.

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    Dragonfly contains remote code execution vulnerability

    CVE-2021-33564 · GHSA-j858-xp5v-f8xx

    Affected
    • RubyGems dragonfly < 1.4.0
    Fixed in
    1.4.0· Vendor fix available
    Issue
    An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verifyurl option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedRubyGemsPublished

    Dragonfly Code Injection vulnerability

    CVE-2013-1756 · GHSA-p463-639r-q9g9

    Affected
    • RubyGems dragonfly >= 0.7, < 0.8.6; >= 0.9, < 0.9.13
    Fixed in
    0.9.130.8.6· Vendor fix available
    Issue
    The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute arbitrary code via a crafted request.

    Recommended action: Upgrade to 0.9.13 or 0.8.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →