Skip to content

← Public intelligence

RubyGems package

devise_token_auth

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1RubyGemsPublished

    Devise Token Auth vulnerable to Cross-site Scripting

    CVE-2019-16751 · GHSA-mvqr-r76c-wm5f

    Affected
    • RubyGems devise_token_auth >= 0.1.33, < 1.1.3
    Fixed in
    1.1.3· Vendor fix available
    Issue
    An issue was discovered in Devise Token Auth through 1.1.2. The omniauth failure endpoint is vulnerable to Reflected Cross Site Scripting (XSS) through the message parameter. Unauthenticated attackers can craft a URL that executes a malicious JavaScript payload in the victim's browser. This affects the fallbackrender method in the omniauth callbacks controller.

    Recommended action: Upgrade to 1.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →