Skip to content

← Public intelligence

RubyGems package

delayed_job_web

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1RubyGemsPublished

    delayed_job_web Cross-site Scripting vulnerability

    CVE-2017-12097 · GHSA-w7q9-xr2x-wh7x

    Affected
    • RubyGems delayed_job_web >= 1.2.9, < 1.4.2
    Fixed in
    1.4.2· Vendor fix available
    Issue
    An exploitable cross site scripting (XSS) vulnerability exists in the filter functionality of the delayedjobweb rails gem versions 1.2.9 before 1.4.2. A specially crafted URL can cause an XSS flaw resulting in an attacker being able to execute arbitrary javascript on the victim's browser. An attacker can phish an authenticated user to trigger this vulnerability.

    Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →