UnratedRubyGemsPublished
Cocaine Gem OS Command Injection vulnerability
CVE-2013-4457 · GHSA-c43v-hrmg-56r4
- Affected
- RubyGems cocaine >= 0.4.0, < 0.5.3
- Fixed in
- 0.5.3· Vendor fix available
- Issue
- The Cocaine gem 0.4.0 through 0.5.2 for Ruby allows context-dependent attackers to execute arbitrary commands via a crafted has object, related to recursive variable interpolation.
Recommended action: Upgrade to 0.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.