Skip to content

← Public intelligence

RubyGems package

chartkick

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1RubyGemsPublished

    CSS Injection in Chartkick gem

    CVE-2020-16254 · GHSA-3j95-fjv2-3m4p

    Affected
    • RubyGems chartkick < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    The Chartkick gem through 3.3.2 for Ruby allows Cascading Style Sheets (CSS) Injection (without attribute).

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.3RubyGemsAmendedPublished

    Prototype Pollution in chartkick

    CVE-2019-18841 · GHSA-5pm8-492c-92p5

    Affected
    • RubyGems chartkick < 3.3.0
    Fixed in
    3.3.0· Vendor fix available
    Issue
    Affected versions of @polymer/polymer are vulnerable to prototype pollution. The package fails to prevent modification of object prototypes through chart options containing a payload such as {"proto": {"polluted": true}}. It is possible to achieve the same results if a chart loads data from a malicious server. Recommendation Upgrade to version 3.2.0 or later.

    Recommended action: Upgrade to 3.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 4.7RubyGemsPublished

    Cross-site Scripting in Chartkick

    CVE-2019-12732 · GHSA-g45g-g52h-39rg

    Affected
    • RubyGems chartkick < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    The Chartkick gem through 3.1.0 for Ruby allows XSS.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →