Medium, CVSS 5.5RubyGemsPublished
cairo is vulnerable to denial of service due to a null pointer dereference
CVE-2017-7475 · GHSA-5v3f-73gv-x7x5
- Affected
- RubyGems cairo >= 1.15.4, <= 1.15.4
- Fixed in
- 1.15.5· Vendor fix available
- Issue
- Cairo version 1.15.4 is vulnerable to a NULL pointer dereference related to the FTLoadGlyph and FTRenderGlyph resulting in an application crash.
Recommended action: Upgrade to 1.15.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.