Critical, CVSS 9.8RubyGemsPublished
BibTeX-Ruby vulnerable to OS command injection
CVE-2019-10780 · GHSA-c5r5-7pfh-6qg6
- Affected
- RubyGems bibtex-ruby <= 5.0.1
- Fixed in
- 5.1.0· Vendor fix available
- Issue
- BibTeX-ruby before 5.1.0 allows shell command injection due to unsanitized user input being passed directly to the built-in Ruby Kernel.open method through BibTeX.open.
Recommended action: Upgrade to 5.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.