Medium, CVSS 6.5RubyGemsPublished
apollo_upload_server has Denial of Service vulnerability
CVE-2021-39880 · GHSA-w6pv-c757-6rgr
- Affected
- RubyGems apollo_upload_server < 2.1.0
- Fixed in
- 2.1.0· Vendor fix available
- Issue
- A Denial Of Service vulnerability in the apollouploadserver Ruby gem in GitLab CE/EE version 11.11 and above allows an attacker to deny access to all users via specially crafted requests to the apollouploadserver middleware.
Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.