Skip to content

← Public intelligence

RubyGems package

administrate

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4RubyGemsPublished

    administrate vulnerable to Cross-Site Request Forgery

    CVE-2016-3098 · GHSA-cc8c-26rj-v2vx

    Affected
    • RubyGems administrate < 0.1.5
    Fixed in
    0.1.5· Vendor fix available
    Issue
    Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.

    Recommended action: Upgrade to 0.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.7RubyGemsPublished

    Sort order SQL injection in Administrate

    CVE-2020-5257 · GHSA-2p5p-m353-833w

    Affected
    • RubyGems administrate < 0.13.0
    Fixed in
    0.13.0· Vendor fix available
    Issue
    In Administrate (rubygem) before version 0.13.0, when sorting by attributes on a dashboard, the direction parameter was not validated before being interpolated into the SQL query. This could present a SQL injection if the attacker were able to modify the direction parameter and bypass ActiveRecord SQL protections. Whilst this does have a high-impact, to exploit this you need access to the Administrate dashboards, which we would expect to be behind authentication. This is patched in wersion 0.13.0.

    Recommended action: Upgrade to 0.13.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →