Medium, CVSS 5.3RubyGemsPublished
activemodel contains Improper Input Validation
CVE-2016-0753 · GHSA-543v-gj2c-r3ch
- Affected
- RubyGems activemodel >= 4.1.0, <= 4.1.14.0; >= 4.2.0, <= 4.2.5.0
- Fixed in
- 4.1.14.14.2.5.1· Vendor fix available
- Issue
- Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.
Recommended action: Upgrade to 4.2.5.1 or 4.1.14.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.