Skip to content

← Public intelligence

RubyGems package

activejob

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.6RubyGemsPublished

    Active Job - Object injection security vulnerability

    GHSA-mpwp-4h2m-765c

    Affected
    • RubyGems activejob < 4.2.0.beta2
    Fixed in
    4.2.0.beta2· Vendor fix available
    Issue
    Active Job vulnerability: An Active Job bug allowed String arguments to be deserialized as if they were Global IDs, an object injection security vulnerability.

    Recommended action: Upgrade to 4.2.0.beta2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5RubyGemsPublished

    Improper Access Control in activejob

    CVE-2018-16476 · GHSA-q2qw-rmrh-vv42

    Affected
    • RubyGems activejob >= 4.2.0, < 4.2.11; >= 5.0.0, <= 5.0.7.0; >= 5.1.0, <= 5.1.6.0; >= 5.2.0, <= 5.2.1.0
    Fixed in
    5.0.7.15.2.1.15.1.6.14.2.11· Vendor fix available
    Issue
    A Broken Access Control vulnerability in Active Job versions = 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have.

    Recommended action: Upgrade to 5.2.1.1, 5.1.6.1, 5.0.7.1 or 4.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →