Critical, CVSS 9.8PackagistPublished
ZendFramework vulnerable to XXE/XEE attacks
GHSA-f4fj-q6m4-cc52
- Affected
- Packagist zendframework/zend-xmlrpc >= 2.1.0, < 2.1.6; >= 2.2.0, < 2.2.6
- Fixed in
- 2.2.62.1.6· Vendor fix available
- Issue
- Numerous components utilizing PHP's DOMDocument, SimpleXML, and xmlparse functionality are vulnerable to two types of attacks: - XML eXternal Entity (XXE) Injection attacks. The above mentioned extensions are insecure by default, allowing external entities to be specified by adding a specific DOCTYPE element to XML documents and strings. By exploiting this vulnerability an application may be coerced to open arbitrary files and/or TCP connections. - XML Entity Expansion (XEE) vectors, leading to Denial of Service vectors. XEE attacks occur when the XML DOCTYPE declaration includes XML entity definitions that contain either recursive or circular references; this leads to CPU and memory consumption, making Denial of Service exploits trivial to implement.
Recommended action: Upgrade to 2.2.6 or 2.1.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.