Skip to content

← Public intelligence

Packagist package

zendframework/zend-navigation

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    Zend-Navigation vulnerable to Cross-site Scripting

    GHSA-6v7p-5qcq-268c

    Affected
    • Packagist zendframework/zend-navigation >= 2.0.0, < 2.2.7; >= 2.3.0, < 2.3.1
    Fixed in
    2.2.72.3.1· Vendor fix available
    Issue
    Many Zend Framework 2 view helpers were using the escapeHtml() view helper in order to escape HTML attributes, instead of the more appropriate escapeHtmlAttr(). In situations where user data and/or JavaScript is used to seed attributes, this can lead to potential cross site scripting (XSS) attack vectors. Vulnerable view helpers include: - All Zend\Form view helpers. - Most Zend\Navigation (aka Zend\View\Helper\Navigation\) view helpers. - All "HTML Element" view helpers: htmlFlash(), htmlPage(), htmlQuickTime(). - Zend\View\Helper\Gravatar

    Recommended action: Upgrade to 2.3.1 or 2.2.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →