Skip to content

← Public intelligence

Packagist package

zendframework/zend-mail

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8PackagistPublished

    Zend-Mail remote code execution in zend-mail via Sendmail adapter

    GHSA-cxf7-m5g2-v594

    Affected
    • Packagist zendframework/zend-mail >= 2.0.0, < 2.4.11; >= 2.5.0, < 2.7.2
    Fixed in
    2.7.22.4.11· Vendor fix available
    Issue
    When using the zend-mail component to send email via the Zend\Mail\Transport\Sendmail transport, a malicious user may be able to inject arbitrary parameters to the system sendmail program. The attack is performed by providing additional quote characters within an address; when unsanitized, they can be interpreted as additional command line arguments, leading to the vulnerability. The following example demonstrates injecting additional parameters to the sendmail binary via the From address: The attack works because zend-mail filters the email addresses using the RFC 3696 specification, where the string "AAA\" params injection"@domain is considered a valid address. This validation is provided using the zend-validator component with the following parameters: The above accepts local domain with any string specified by double quotes as the local part. While this is valid per RFC 3696, due to the fact that sender email addresses are provided to the sendmail binary via the command line,…

    Recommended action: Upgrade to 2.7.2 or 2.4.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    zend-mail remote code execution via Sendmail adapter

    CVE-2016-10034 · GHSA-r9mw-gwx9-v3h5

    Affected
    • Packagist zendframework/zend-mail < 2.4.11; >= 2.5, <= 2.5.2; >= 2.6, <= 2.6.2; >= 2.7, < 2.7.2
    Fixed in
    2.7.22.4.11· Partial vendor fix
    Issue
    The setFrom function in the Sendmail adapter in the zend-mail component before 2.4.11, 2.5.x, 2.6.x, and 2.7.x before 2.7.2, and Zend Framework before 2.4.11 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted e-mail address.

    Recommended action: Upgrade to 2.7.2 or 2.4.11 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →