Skip to content

← Public intelligence

Packagist package

zendframework/zend-db

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PackagistPublished

    Zend Framework SQL injection vulnerability

    CVE-2014-8089 · GHSA-qh9w-r7g5-q939

    Affected
    • Packagist zendframework/zend-db >= 2.0.0, < 2.0.99; >= 2.1.0, < 2.1.99; >= 2.2.0, < 2.2.8; >= 2.3.0, < 2.3.3
    Fixed in
    2.2.82.3.32.0.992.1.99· Vendor fix available
    Issue
    SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.

    Recommended action: Upgrade to 2.3.3, 2.2.8, 2.1.99 or 2.0.99 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Zend Framework Allows SQL Injection

    CVE-2015-0270 · GHSA-v59p-p692-v382

    Affected
    • Packagist zendframework/zend-db < 2.2.10; >= 2.3.0, < 2.3.5
    Fixed in
    2.2.102.3.5· Vendor fix available
    Issue
    Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.

    Recommended action: Upgrade to 2.3.5 or 2.2.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →