High, CVSS 7.5PackagistPublished
Zend Framework Information Disclosure
CVE-2015-7503 · GHSA-pm9m-w23q-5967
- Affected
- Packagist zendframework/zend-crypt >= 2.0.0, < 2.4.9; >= 2.5.0, < 2.5.2
- Fixed in
- 2.5.22.4.9· Vendor fix available
- Issue
- Zend Framework before 2.4.9, zend-framework/zend-crypt 2.4.x before 2.4.9, and 2.5.x before 2.5.2 allows remote attackers to recover the RSA private key.
Recommended action: Upgrade to 2.5.2 or 2.4.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.