Skip to content

← Public intelligence

Packagist package

zendframework/zend-captcha

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    Zend-Captcha Information Disclosure and Insufficient Entropy vulnerability

    GHSA-mg4x-prh7-g4mx

    Affected
    • Packagist zendframework/zend-captcha >= 2.0.0, < 2.4.9; >= 2.5.0, < 2.5.2
    Fixed in
    2.5.22.4.9· Vendor fix available
    Issue
    In Zend Framework, ZendCaptchaWord (v1) and Zend\Captcha\Word (v2) generate a "word" for a CAPTCHA challenge by selecting a sequence of random letters from a character set. Prior to this advisory, the selection was performed using PHP's internal arrayrand() function. This function does not generate sufficient entropy due to its usage of rand() instead of more cryptographically secure methods such as opensslpseudorandombytes(). This could potentially lead to information disclosure should an attacker be able to brute force the random number generation.

    Recommended action: Upgrade to 2.5.2 or 2.4.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →