Critical, CVSS 9.8PackagistPublished
SQL Injection in usmanhalalit/pixie
CVE-2019-10766 · GHSA-68wg-qv6r-j4vp
- Affected
- Packagist usmanhalalit/pixie < 1.0.3; >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.21.0.3· Vendor fix available
- Issue
- Pixie versions 1.0.x before 1.0.3, and 2.0.x before 2.0.2 allow SQL Injection in the limit() function due to improper sanitization.
Recommended action: Upgrade to 2.0.2 or 1.0.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.