Skip to content

← Public intelligence

Packagist package

thorsten/phpmyfaq

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

110 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PackagistPublished

    phpMyFAQ Improper Authentication vulnerability

    CVE-2023-0311 · GHSA-g92r-9rxw-cmgx

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.10
    Fixed in
    3.1.10· Vendor fix available
    Issue
    Improper Authentication in GitHub repository thorsten/phpmyfaq prior to 3.1.10.

    Recommended action: Upgrade to 3.1.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    phpMyFAQ Reflected Cross-site Scripting vulnerability

    CVE-2023-0314 · GHSA-m9xr-8cx7-53pj

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.10
    Fixed in
    3.1.10· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.10.

    Recommended action: Upgrade to 3.1.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4PackagistPublished

    phpMyFAQ vulnerable to Cross-site Scripting

    CVE-2022-4408 · GHSA-rjf6-wj7r-5fj2

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.9
    Fixed in
    3.1.9· Vendor fix available
    Issue
    phpMyFAQ prior to version 3.1.9 is vulnerable to stored Cross-site Scripting (XSS).

    Recommended action: Upgrade to 3.1.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1PackagistPublished

    phpMyFAQ vulnerable to Cross-site Scripting

    CVE-2022-4407 · GHSA-cp9c-phxx-55xm

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.9
    Fixed in
    3.1.9· Vendor fix available
    Issue
    phpMyFAQ prior to version 3.1.9 is vulnerable to reflected Cross-site Scripting (XSS).

    Recommended action: Upgrade to 3.1.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5PackagistPublished

    phpMyFAQ has insecure HTTP cookies

    CVE-2022-4409 · GHSA-wpgc-5cr5-h9gg

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.9
    Fixed in
    3.1.9· Vendor fix available
    Issue
    phpMyFAQ is contains Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in versions prior to 3.1.9.

    Recommended action: Upgrade to 3.1.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 6.1PackagistPublished

    phpMyFAQ vulnerable to reflected Cross-site Scripting

    CVE-2022-3766 · GHSA-mg5h-rhjq-6v84

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.8
    Fixed in
    3.1.8· Vendor fix available
    Issue
    phpMyFAQ prior to version 3.1.8 is vulnerable to reflected cross-site scripting.

    Recommended action: Upgrade to 3.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 5.4PackagistPublished

    phpMyFAQ vulnerable to stored Cross-site Scripting

    CVE-2022-3765 · GHSA-wr74-2v66-57pp

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.8
    Fixed in
    3.1.8· Vendor fix available
    Issue
    phpMyFAQ prior to version 3.1.8 is vulnerable to stored Cross-site Scripting.

    Recommended action: Upgrade to 3.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Critical, CVSS 9.8PackagistPublished

    phpMyFAQ contains Weak Password Requirements

    CVE-2022-3754 · GHSA-2rr3-rv49-p42f

    Affected
    • Packagist thorsten/phpmyfaq < 3.1.8
    Fixed in
    3.1.8· Vendor fix available
    Issue
    phpMyFAQ prior to version 3.1.8 has Weak Password Requirements. Version 3.1.8 introduces an eight-character minimum password length.

    Recommended action: Upgrade to 3.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. High, CVSS 8.4PackagistPublished

    phpMyFAQ vulnerable to Cross-site Scripting

    CVE-2022-3608 · GHSA-6rj8-9cm9-6gff

    Affected
    • Packagist thorsten/phpmyfaq <= 3.1.7
    Fixed in
    3.2.0-alpha· Vendor fix available
    Issue
    phpMyFAQ versions 3.1.7 and prior are vulnerable to stored cross-site scripting (XSS). A patch is available on the main branch of the repository and anticipated to be part of version 3.2.0-alpha.

    Recommended action: Upgrade to 3.2.0-alpha (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  10. High, CVSS 8.8PackagistPublished

    phpMyFAQ CSRF

    CVE-2018-16650 · GHSA-p57w-9q28-j6v7

    Affected
    • Packagist thorsten/phpmyfaq < 2.9.11
    Fixed in
    2.9.11· Vendor fix available
    Issue
    phpMyFAQ before 2.9.11 allows CSRF.

    Recommended action: Upgrade to 2.9.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →