Critical, CVSS 9.8PackagistPublished
Improper Input Validation in Symfony
CVE-2019-11325 · GHSA-w4rc-rx25-8m86
- Affected
- Packagist symfony/var-exporter >= 4.2.0, < 4.2.12; >= 4.3.0, < 4.3.8
- Fixed in
- 4.2.124.3.8· Vendor fix available
- Issue
- An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.
Recommended action: Upgrade to 4.3.8 or 4.2.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.