Medium, CVSS 5.9PackagistPublished
Symfony CSRF Vulnerability
CVE-2017-16653 · GHSA-92x6-h2gr-8gxq
- Affected
- Packagist symfony/security-csrf >= 2.7.0, < 2.7.38; >= 2.8.0, < 2.8.31; >= 3.0.0, < 3.2.14; >= 3.3.0, < 3.3.13
- Fixed in
- 2.8.312.7.383.3.133.2.14· Vendor fix available
- Issue
- An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version =2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.
Recommended action: Upgrade to 3.3.13, 3.2.14, 2.8.31 or 2.7.38 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.