Critical, CVSS 9.8PackagistPublished
Symfony Service IDs Allow Injection
CVE-2019-10910 · GHSA-pgwj-prpq-jpc2
- Affected
- Packagist symfony/proxy-manager-bridge >= 2.7.0, < 2.7.51; >= 2.8.0, < 2.8.50; >= 3.0.0, < 3.4.26; >= 4.0.0, < 4.1.12; >= 4.2.0, < 4.2.7
- Fixed in
- 2.8.504.1.122.7.514.2.73.4.26· Vendor fix available
- Issue
- In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.
Recommended action: Upgrade to 4.2.7, 4.1.12, 3.4.26 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.